理查德·史蒂文斯

W. Richard Stevens
生卒
1951 – 1999
国籍
美国
外文名
W. Richard Stevens

生平与创作

理查德·史蒂文斯(William Richard (Rich) Stevens,1951年2月5日—1999年9月1日),美国计算机科学家,是众多的畅销UNIX、TCP/IP书籍的作者。

生平

史蒂文斯于 1951 年出生于北罗德西亚(今赞比亚)的卢安夏。他的父亲在当地的一家铜厂工作。他的家曾先后搬到盐湖城、新墨西哥的Hurley、华盛顿和南非的帕拉博鲁瓦。史蒂文斯曾就读于位于弗吉尼亚韦恩斯伯勒的Fishburne 军校。并于1973年取得了密歇根大学的航天工程工科学士学位,于1978年取得工科硕士学位,于1982年取得了亚利桑那大学的系统工程学博士学位。他于1975年搬到了土桑并受雇于当地的 基特峰国家天文台担任程序员工作,并在那里工作到1982年。 从1982年到1990年,他在位于纽哈芬市, CT的Health Systems International担任计算机服务副总监。他于1990年搬回了土桑,在他的专业领域从事写作和顾问工作。 他在20世纪70年还曾狂热地从事飞行运动并担任兼职飞行教练工作。

著作

1990年 - “UNIX Network Programming” - ISBN 0-139-49876-1

1992年 - Advanced Programming in the UNIX Environment - ISBN 0-201-56317-7

国际中文版 ISBN 986-7727-82-7

1994年 - TCP/IP Illustrated, Volume 1: The Protocols - ISBN 0-201-63346-9

国际中文版 初版 ISBN 957-0390-29-8 二版 ISBN 9867727878

1995年 - TCP/IP Illustrated, Volume 2: The Implementation (with Gary R. Wright) - ISBN 0-201-63354-X

国际中文版 上 ISBN 957-0390-32-8 下 ISBN 957-0390-35-2

1996年 - TCP/IP Illustrated, Volume 3: TCP for Transactions, HTTP, NNTP, and the UNIX Domain Protocols - ISBN 0-201-63495-3

1998年 - UNIX Network Programming, Volume 1, Second Edition: Networking APIs: Sockets and XTI - ISBN 0-134-90012-X

繁体中文版《UNIX 网络程式设计:网络应用程序设计界面:Sockets 与 XTI》 ISBN 986-7790-42-1

1999年 - UNIX Network Programming, Volume 2, Second Edition: Interprocess Communications - ISBN 0-130-81081-9

繁体中文版《UNIX 网络程式设计:IPC 行程间通讯程式设计》 ISBN 986-7790-42-1

RFC

Stevens 还协助制定了一些 IETF 的 RFC 文件。 — 一些BSD套接字 API针对IPv6的更新文档 和一个 TCP 拥塞控制方面的标准文档。

Stevens, W. R., and Thomas, M. 1998年. "Advanced Sockets API for IPv6," RFC 2292

Gilligan, R. E., Thomson, S., Bound, J., and Stevens, W. R. 1999年. "Basic Socket Interface Extensions for IPv6," RFC 2553

Allman, M., Paxson, V., Stevens, W. R. 1999年. "TCP Congestion Control," RFC 2581

以上文字摘自维基百科「理查德·史蒂文斯」(去掉了参考文献等尾部小节),按 CC BY-SA 4.0 使用,作者为维基百科的各位编者。

资料卡

出生
1951 年 2 月 5 日
出生地
赞比亚
逝世
1999 年 9 月 1 日
逝世地
图森
职业
作家、计算机科学家
使用语言
英语
就读学校
密歇根大学、Fishburne Military School
领域
系统工程
代表作
UNIX环境高级编程、TCP/IP illustrated. Volume 1, The protocols (2012)

资料卡来自 Wikidata Q949125(CC0),众包数据,个别字段可能不全。

本站收录的作品(2)

作品年表(3 本)

本站书库里署名理查德·史蒂文斯的书(Open Library 上至少 10 人加过书架的才收),按首版年份排(有本站书页的用 Wikidata 记的首版年,其余用 Open Library 的);年份偶尔记成后来的版本或译本,以原书为准。全部作品见 Open Library。

  1. 1990Unix Network Programming书架 16
  2. 1992UNIX环境高级编程Advanced programming in the Unix environment书架 33
  3. 1993TCP/IP Illustrated书架 50

同时代的美国作家

资料来源